GameCenter Not Compatible With iPhone 3G, iPhone 1st gen

The news just came in yesterday that GameCenter is not compatible with the iPhone 3G or 1st gen iPhone (along with the 1st gen iPod touch), displaying a sign that Apple is slowly weeding out the earlier models.

Good news for people with iPod touch 2nd gens though: your device is included in the compatible devices list.  This is mostly due to the fact that the iPod touch is a little bit faster than the iPhone because of the lack of phone capabilities.

So for those holding an iPhone 3G or lower, don’t be expecting anymore love from Apple anytime soon.

About Daniel

I have been an iPhone game addict ever since the NES emulator came out on the 1.1.4 iPhone 2G. After 2.0 and the App Store came out, my iPhone homescreen has never been the same. Other than writing reviews for App Store games, I play soccer/football, American football, volleyball, and golf. I love going to the beach and fishing on the pier. Some games not available on iPhone/iPod Touch that I truly love are the Call of Duty series, Guitar Hero III, Madden NFL 09, and PGR: Gotham Racing.

Leave a Reply

Your email address will not be published. Required fields are marked *